openSuSE
Username:
Password:
Linki sponsorowane: | inwestycje | erasmus in warsaw
Strony: [1]
  Drukuj  
Autor Wątek: Grafika ATI - problem ze sterownikami, 3D, xorg.conf i niestandard. rozdzielcz.  (Przeczytany 6486 razy)
0 użytkowników i 1 Gość przegląda ten wątek.
HarryPotter
*
Offline Offline

Wiadomości: 9


« : Luty 08, 2008, 16:56:18 »

Mam openSuSE 10.3 i Radeona 9200SE (wiem, że to prehistoryczny zabytek, ale nic na to nie poradzę). Potrzebowałem w swoim SuSku ustawić niestandardową rozdzielczość 1280x768. Na pewnym forum poradzono mi zainstalować zamknięte sterowniki, jednak okazało się, że stara ich wersja nie obsługuje najnowszego Xorga, a nowsza działa tylko od 9500 wzwyż. X-server wywalił "no screens found". Według tego (http://forum.suse.pl/index.php/topic,17131.0.html) tematu uaktywniłem z powrotem otwarte sterowniki. Przestała działać jednak akceleracja 3D. Podano mi link do tego (http://forum.suse.pl/index.php/topic,17131.msg114355.html#msg114355) posta, lecz po komendzie "sax2 -a" wrócił "no screen found".


http://www.wklej.org/id/271422a375 - mój Xorg.conf (zauważyłem, że tam jeszcze siedzi fglrx)
Tutaj (http://forum.dobreprogramy.pl/viewtopic.php?f=14&t=220162&st=0&sk=t&sd=a) jest mój wątek na tamtym forum.
Zapisane
przemokoch
Przyjaciel
*
Offline Offline

Wiadomości: 97


« Odpowiedz #1 : Luty 09, 2008, 09:19:08 »

To sprubuj z vesa ostatecznie
 
Kod:
init 3
sax2 -r -m 0=vesa
init 5

Jak te załapią możesz jeszcze raz spróbować  z otwartymi do radeona

Kod:
init 3
sax2 -r -m 0=radeon
init 5

Co do zamkniętych to z tą kartą są duże problemy
Sam mam ati-tragedia-2600xt
Zapisane
HarryPotter
*
Offline Offline

Wiadomości: 9


« Odpowiedz #2 : Luty 11, 2008, 18:59:32 »

VESA nie załapały w ogóle (wywaliły 5 razy pod rząd błąd, który cytuję poniżej), otwarte odpaliły, ale bez 3D (glxinfo wywala "Direct rendering: No"). Rozdzielczości nadal nie mogę ustawić. Co ciekawe gdy włączę w SaX-ie obsługę dwóch monitorów, w ustawieniach drugiego monitora jest rozdziałka 1280x768, jednak jej ustawienie nic nie daje (co jest chyba logiczne, bo mam tylko jeden monitor). W SaX-ie nie ma już śladu po fglrx, dopisałem też 1280x768 łącznie z Modelines, lecz nic to nie dało - ciągle nie mam 1280x768 w SaX-ie.

Przy przestawianiu na VESĘ (za pomocą komendy na sax2) wyskoczył błąd:
Kod:
Parse error on line 146 of section Device in file /etc/X11/corg.conf
     "XaaNoOffscreenPixmaps" is not a valid keyword in this section.
Problem when parsing config file.
Could not import file /etc/X11/xorg.conf at /usr/bin/isax line 127.

Mój xorg: http://www.wklej.org/id/7375cce2cf
Zapisane
przemokoch
Przyjaciel
*
Offline Offline

Wiadomości: 97


« Odpowiedz #3 : Luty 12, 2008, 10:49:14 »

Znalazłem coś o otwartych i 3d do twojej karty.
http://peb.pl/linux/201349-ati-radeon-9200-beryl.html (http://peb.pl/linux/201349-ati-radeon-9200-beryl.html)
http://debian.linux.pl/printview.php?t=952&start=0&sid=fa2ab8e771c921137780cffa8d764480
 (http://debian.linux.pl/printview.php?t=952&start=0&sid=fa2ab8e771c921137780cffa8d764480)
« Ostatnia zmiana: Luty 12, 2008, 11:54:58 wysłane przez przemokoch » Zapisane
HarryPotter
*
Offline Offline

Wiadomości: 9


« Odpowiedz #4 : Luty 12, 2008, 16:24:12 »

Na podstawie linku nr 2:
Cytuj
W przypadku kiedy korzystasz z otwartych sterowników, a nie masz przyśpieszenia sprzętowego i Twoja karta graficzna jest wspierana przez otwarte stery, powodem takiego stanu rzeczy może być brak odpowiednich pakietów. Upewnij się, że posiadasz pakiety: libgl1-mesa-dri, libgl1-mesa-glx, libglu1-mesa, mesa-common-dev, mesa-utils, xlibmesa-dri, xlibmesa-glu. W przypadku braku jakiegoś pakietu, zainstaluj go.

Tych pakietów nie ma w repozytorium.

Co mam zrobić, żeby ustawić tą rozdzielczość? Tak, jak napisałem wcześniej, wpisy w xorg.conf nic nie dały.
Zapisane
przemokoch
Przyjaciel
*
Offline Offline

Wiadomości: 97


« Odpowiedz #5 : Luty 12, 2008, 19:33:14 »

Ten drugi link dotyczył debiana potraktuj jako wskazówki jedynie.
.Z tego co zrozumiałem to nie masz opcji do wyboru 1280x768 to w sekcji monitor w sax2  ustaw LCD tam jest taka rozdzielczość. Ostrożnie z odświerzaniem.
Zapisane
HarryPotter
*
Offline Offline

Wiadomości: 9


« Odpowiedz #6 : Luty 12, 2008, 20:18:16 »

Tak miałem ustawione wcześniej (1280x768@60Hz - taki monitor), lecz nie mogłem ustawić takiej rozdzielczości.
Zapisane
przemokoch
Przyjaciel
*
Offline Offline

Wiadomości: 97


« Odpowiedz #7 : Luty 12, 2008, 20:39:55 »

Gdzieś pzreczytałem że komuś pomogło podłlączenie monitora przez D-sub zamiast DVI( o ile masz taką możliwość) , pewno nie pomorze ,ale spróbować można. 
Zapisane
HarryPotter
*
Offline Offline

Wiadomości: 9


« Odpowiedz #8 : Luty 13, 2008, 21:28:02 »

Niestety nie mam takiej możliwości. Mój Radeon (9200SE od Gigabyte'a), jak i mój monitor (Hyundai X90W, rozpoznawany jako Hitachi) mają tylko złącze VGA (nie wiem, jak to się fachowo nazywa - jest to ciemnoniebieskie gniazdko w kształcie trapezu równoramiennego).
Zapisane
Strony: [1]
  Drukuj  
 
Skocz do:  

erasmus - serwis komputerowy lubin - projektowanie stron lubin - cuprum lubin - projektowanie stron - zaproszenia lockerz - notatki studenckie
Template modified by designworld.pl