Forum SuSEK - Portal użytkowników OpenSuSE

SuSEK - strona OpenSuSE => How To => Wątek zaczęty przez: sir_lucjan Grudzień 06, 2010, 19:50:50



Tytuł: [How To]Instalujemy najnowszą wersję Tlen w openSUSE
Wiadomość wysłana przez: sir_lucjan Grudzień 06, 2010, 19:50:50
Najnowsza wersja komunikatora Tlen (tj. 7.0.1.71) przestała działać po aktualizacji? Dzieje się tak dlatego, że wymaga to Qt w wersji 4.7 natomiast w systemie mamy tylko Qt 4.6 - niezależnie od tego czy mamy repozytoria KDE Stable czy KDE Upstream. Spokojnie, jest na to rada. Na sam początek udajemy się na stronę:

http://en.opensuse.org/KDE_repositories

i za pomocą YaST dodajemy odpowiednie repozytorium:

Kod:
http://download.opensuse.org/repositories/KDE:/Qt/openSUSE_11.3/

Następnie w konsoli wydajemy polecenie:

Kod:
su

wpisujemy nasze hasło i następnie

Kod:
zypper dup

Powiadomienie w konsoli pokazuje nam, że jedna wersja pakietu zostanie cofnięta - akceptujemy to bez słowa.

Dokładniej chodzi o ten o to pakiet:

Kod:
python-qt4

Jak napisałem wyżej - akceptujemy wszystko. Jak się zainstaluje, odpalamy program Dodaj/usuń programy i odszukujemy "cofnięty" pakiet - zaznaczamy aktualizację i akceptujemy wszystko.

Następnie wykonujemy reboot - to dlatego, by sprawdzić, czy wszystko jest dobrze. W moim przypadku nie wykazało błędów - nie gwarantuję jednak, że będzie tak w każdym przypadku. W razie problemów typu

Cytuj
kdeinit4 cannot start. check your instalation

logujemy się na IceWM, usuwamy dodany wpis za pomocą YaST i ponownie wykonujemy w konsoli:

Kod:
su

wpisujemy nasze hasło i następnie

Kod:
zypper dup

i wszystko wróci do stanu poprzedniego.

Jeśli mieliśmy szczęście i wszystko działa, możemy cieszyć się w pełni działającą najnowszą wersją Tlena.